using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""";
string substitution = @"";
string input = @"aaa|bbb|ccc|""ddd,eee""|""fff,ggg""
""aaa,bbb""|ccc|ddd|""eee,fff""
""aaa,bbb""|""ccc,ddd""|""eee,fff""|ggg";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}