use strict;
my $str = 'aaa|bbb|ccc|"ddd,eee"|"fff,ggg"
"aaa,bbb"|ccc|ddd|"eee,fff"
"aaa,bbb"|"ccc,ddd"|"eee,fff"|ggg';
my $regex = qr/"/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";