import re
regex = re.compile(r"\"")
test_str = ("aaa|bbb|ccc|\"ddd,eee\"|\"fff,ggg\"\n"
"\"aaa,bbb\"|ccc|ddd|\"eee,fff\"\n"
"\"aaa,bbb\"|\"ccc,ddd\"|\"eee,fff\"|ggg")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)