import Foundation
let pattern = #"""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
aaa|bbb|ccc|"ddd,eee"|"fff,ggg"
"aaa,bbb"|ccc|ddd|"eee,fff"
"aaa,bbb"|"ccc,ddd"|"eee,fff"|ggg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)