re = /"/
str = 'aaa|bbb|ccc|"ddd,eee"|"fff,ggg"
"aaa,bbb"|ccc|ddd|"eee,fff"
"aaa,bbb"|"ccc,ddd"|"eee,fff"|ggg'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result