using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=(""|')(.+?)(""|')";
string substitution = @"href=$1docs.google.com/viewer?url=$2$1";
string input = @"<a href=""http://www.sample.ru/docs/price.pdf"" alt=""цены"">прайс</a>
<a href=""https://public.library.ru/menu.pdf"" data-order=""52"">менюшечка</a>
<a href=""https://yandex.ru/web/shtrafy.pdf"">штрафы</a>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}