$re = '/href=("|\')(.+?)("|\')/';
$str = '<a href="http://www.sample.ru/docs/price.pdf" alt="цены">прайс</a>
<a href="https://public.library.ru/menu.pdf" data-order="52">менюшечка</a>
<a href="https://yandex.ru/web/shtrafy.pdf">штрафы</a>';
$subst = "href=$1docs.google.com/viewer?url=$2$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;