import Foundation
let pattern = #"href=("|')(.+?)("|')"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<a href="http://www.sample.ru/docs/price.pdf" alt="цены">прайс</a>
<a href="https://public.library.ru/menu.pdf" data-order="52">менюшечка</a>
<a href="https://yandex.ru/web/shtrafy.pdf">штрафы</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"href=$1docs.google.com/viewer?url=$2$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)