// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"href=("|')(.+?)("|')"#).unwrap();
let string = "<a href=\"http://www.sample.ru/docs/price.pdf\" alt=\"цены\">прайс</a>
<a href=\"https://public.library.ru/menu.pdf\" data-order=\"52\">менюшечка</a>
<a href=\"https://yandex.ru/web/shtrafy.pdf\">штрафы</a>";
let substitution = "href=$1docs.google.com/viewer?url=$2$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}