const regex = /href=("|')(.+?)("|')/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href=("|\')(.+?)("|\')', 'g')
const str = `<a href="http://www.sample.ru/docs/price.pdf" alt="цены">прайс</a>
<a href="https://public.library.ru/menu.pdf" data-order="52">менюшечка</a>
<a href="https://yandex.ru/web/shtrafy.pdf">штрафы</a>`;
const subst = `href=$1docs.google.com/viewer?url=$2$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);