# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^(?:[^|]*\|){8}|(?<!^)\G)[^|\n]*\K\|/ /gm;t' <<< "1|2|1400|34|A|309|Frank|william|This|is|the|line|here|
1|2|1400|34|A|309|Frank|william|This|is|the|line|here|"