using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^(?:[^|]*\|){8}|(?<!^)\G)[^|\n]*\K\|";
string substitution = @" ";
string input = @"1|2|1400|34|A|309|Frank|william|This|is|the|line|here|
1|2|1400|34|A|309|Frank|william|This|is|the|line|here|";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}