import Foundation
let pattern = #"(?:^(?:[^|]*\|){8}|(?<!^)\G)[^|\n]*\K\|"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1|2|1400|34|A|309|Frank|william|This|is|the|line|here|
1|2|1400|34|A|309|Frank|william|This|is|the|line|here|
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)