re = /(?:^(?:[^|]*\|){8}|(?<!^)\G)[^|\n]*\K\|/m
str = '1|2|1400|34|A|309|Frank|william|This|is|the|line|here|
1|2|1400|34|A|309|Frank|william|This|is|the|line|here|'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result