#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+(?=(,? ))(?:\1\w+)+$"
Local $sString = "Valid:" & @CRLF & _
"Lorem Ipsum" & @CRLF & _
"Lorem, Ipsum" & @CRLF & _
"Lorem, Ipsum, Ipsum, Ipsum" & @CRLF & _
"" & @CRLF & _
"Invalid:" & @CRLF & _
"Lorem" & @CRLF & _
"Lorem, Lorem Lorem" & @CRLF & _
"Lorem Lorem, Lorem" & @CRLF & _
"Lorem,Lorem,Lorem" & @CRLF & _
"Lorem, Lorem,Lorem" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")