re = /^\w+(?=(,? ))(?:\1\w+)+$/m
str = 'Valid:
Lorem Ipsum
Lorem, Ipsum
Lorem, Ipsum, Ipsum, Ipsum
Invalid:
Lorem
Lorem, Lorem Lorem
Lorem Lorem, Lorem
Lorem,Lorem,Lorem
Lorem, Lorem,Lorem
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end