import re
regex = re.compile(r"^\w+(?=(,? ))(?:\1\w+)+$", flags=re.MULTILINE)
test_str = ("Valid:\n"
"Lorem Ipsum\n"
"Lorem, Ipsum\n"
"Lorem, Ipsum, Ipsum, Ipsum\n\n"
"Invalid:\n"
"Lorem\n"
"Lorem, Lorem Lorem\n"
"Lorem Lorem, Lorem\n"
"Lorem,Lorem,Lorem\n"
"Lorem, Lorem,Lorem\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")