import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+(?=(,? ))(?:\\1\\w+)+$";
final String string = "Valid:\n"
+ "Lorem Ipsum\n"
+ "Lorem, Ipsum\n"
+ "Lorem, Ipsum, Ipsum, Ipsum\n\n"
+ "Invalid:\n"
+ "Lorem\n"
+ "Lorem, Lorem Lorem\n"
+ "Lorem Lorem, Lorem\n"
+ "Lorem,Lorem,Lorem\n"
+ "Lorem, Lorem,Lorem\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}