using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w+(?=(,? ))(?:\1\w+)+$";
string input = @"Valid:
Lorem Ipsum
Lorem, Ipsum
Lorem, Ipsum, Ipsum, Ipsum
Invalid:
Lorem
Lorem, Lorem Lorem
Lorem Lorem, Lorem
Lorem,Lorem,Lorem
Lorem, Lorem,Lorem
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}