# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\w+\s+\w+\(\w+\s+\*)\w+(\).*)$/\1 \2/;t' <<< "typedef size_t(__cdecl *pfn_fwrite_t)(const void *restrict buffer, size_t size, size_t count, FILE *restrict stream);"