$re = '/^(\w+\s+\w+\(\w+\s+\*)\w+(\).*)$/';
$str = 'typedef size_t(__cdecl *pfn_fwrite_t)(const void *restrict buffer, size_t size, size_t count, FILE *restrict stream);';
$subst = "\1 \2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;