const regex = /^(\w+\s+\w+\(\w+\s+\*)\w+(\).*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w+\\s+\\w+\\(\\w+\\s+\\*)\\w+(\\).*)$', '')
const str = `typedef size_t(__cdecl *pfn_fwrite_t)(const void *restrict buffer, size_t size, size_t count, FILE *restrict stream);`;
const subst = `\1 \2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);