#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(\w+\s+\w+\(\w+\s+\*)\w+(\).*)$"
Local $sString = "typedef size_t(__cdecl *pfn_fwrite_t)(const void *restrict buffer, size_t size, size_t count, FILE *restrict stream);"
Local $sSubst = "\1 \2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)