package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\w+\s+\w+\(\w+\s+\*)\w+(\).*)$`)
var str = []byte(`typedef size_t(__cdecl *pfn_fwrite_t)(const void *restrict buffer, size_t size, size_t count, FILE *restrict stream);`)
var substitution = []byte("\1 \2")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}