import Foundation
let pattern = #"^(\w+\s+\w+\(\w+\s+\*)\w+(\).*)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"typedef size_t(__cdecl *pfn_fwrite_t)(const void *restrict buffer, size_t size, size_t count, FILE *restrict stream);"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 \2"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}