using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![^\s]){[^}]*}\t?";
string input = @"Shutdown Latest News {null}{10/15/2013} {10/15/2013} words words words.
Email Flow in Exchange {null}{10/17/2013} {10/17/2013} words words words....
Should This be banned? {null}{10/23/2013} {10/23/2013} words words words....";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}