import re
regex = re.compile(r"(?<![^\s]){[^}]*}\t?")
test_str = ("Shutdown Latest News {null}{10/15/2013} {10/15/2013} words words words.\n"
"Email Flow in Exchange {null}{10/17/2013} {10/17/2013} words words words....\n"
"Should This be banned? {null}{10/23/2013} {10/23/2013} words words words....")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")