import Foundation
let pattern = #"(?<![^\s]){[^}]*}\t?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Shutdown Latest News {null}{10/15/2013} {10/15/2013} words words words.
Email Flow in Exchange {null}{10/17/2013} {10/17/2013} words words words....
Should This be banned? {null}{10/23/2013} {10/23/2013} words words words....
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)