#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\w\.-ñÑ]+$"
Local $sString = "asd_sdf" & @CRLF & _
"asd" & @CRLF & _
"jose_del_pino_09" & @CRLF & _
"españita" & @CRLF & _
"ESPAÑita" & @CRLF & _
"1969" & @CRLF & _
"56987"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")