$re = '/^[\w\.-ñÑ]+$/m';
$str = 'asd_sdf
asd
jose_del_pino_09
españita
ESPAÑita
1969
56987';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);