package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w\.-ñÑ]+$`)
var str = `asd_sdf
asd
jose_del_pino_09
españita
ESPAÑita
1969
56987`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}