import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\w\\.-ñÑ]+$";
final String string = "asd_sdf\n"
+ "asd\n"
+ "jose_del_pino_09\n"
+ "españita\n"
+ "ESPAÑita\n"
+ "1969\n"
+ "56987";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}