re = /^[\w\.-ñÑ]+$/m
str = 'asd_sdf
asd
jose_del_pino_09
españita
ESPAÑita
1969
56987'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end