// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\w\.-ñÑ]+$").unwrap();
let string = "asd_sdf
asd
jose_del_pino_09
españita
ESPAÑita
1969
56987";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}