# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.)(\d{3})-(.+)(\s*)-(\d{3})\s*-\s*(\d+)/\1...\2...\3...\5...\6/g;t' <<< "ARTICULO
1050-B.BOX 4 LITROS-998-1
1120-Bag in box 10L QCD -998-1
8170-BOLSA 1K POLVO ANONIMO-998-8
4180-BOLSA 2,5K POLVO-998-4"