package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.)(\d{3})-(.+)(\s*)-(\d{3})\s*-\s*(\d+)`)
var str = `ARTICULO
1050-B.BOX 4 LITROS-998-1
1120-Bag in box 10L QCD -998-1
8170-BOLSA 1K POLVO ANONIMO-998-8
4180-BOLSA 2,5K POLVO-998-4`
var substitution = "\1...\2...\3...\5...\6"
fmt.Println(re.ReplaceAllString(str, substitution))
}