const regex = new RegExp('(.)(\\d{3})-(.+)(\\s*)-(\\d{3})\\s*-\\s*(\\d+)', 'g')
const str = `ARTICULO
1050-B.BOX 4 LITROS-998-1
1120-Bag in box 10L QCD -998-1
8170-BOLSA 1K POLVO ANONIMO-998-8
4180-BOLSA 2,5K POLVO-998-4`;
const subst = `\1...\2...\3...\5...\6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);