// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.)(\d{3})-(.+)(\s*)-(\d{3})\s*-\s*(\d+)").unwrap();
let string = "ARTICULO
1050-B.BOX 4 LITROS-998-1
1120-Bag in box 10L QCD -998-1
8170-BOLSA 1K POLVO ANONIMO-998-8
4180-BOLSA 2,5K POLVO-998-4";
let substitution = "\\1...\\2...\\3...\\5...\\6";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}