#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.)(\d{3})-(.+)(\s*)-(\d{3})\s*-\s*(\d+)"
Local $sString = "ARTICULO" & @CRLF & _
"1050-B.BOX 4 LITROS-998-1" & @CRLF & _
"1120-Bag in box 10L QCD -998-1" & @CRLF & _
"8170-BOLSA 1K POLVO ANONIMO-998-8" & @CRLF & _
"4180-BOLSA 2,5K POLVO-998-4"
Local $sSubst = "\1...\2...\3...\5...\6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)