# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.)(\d{3})-(.+)(\s*)-(\d{3})\s*-\s*(\d+)"
test_str = ("ARTICULO\n"
"1050-B.BOX 4 LITROS-998-1\n"
"1120-Bag in box 10L QCD -998-1\n"
"8170-BOLSA 1K POLVO ANONIMO-998-8\n"
"4180-BOLSA 2,5K POLVO-998-4")
subst = "\\1...\\2...\\3...\\5...\\6"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.