package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`ip=(?|0\.0\.0\.0.*?host=(\S+)|(\d+\.\d+\.\d+\.\d+))`)
var str = `Foo bar ip=0.0.0.0 baz host=YOLO-PC foobar bazinga
Foo bar ip=12.23.34.45 baz host=FOOBAR-PC foobar bazinga`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}