import re
regex = re.compile(r"ip=(?|0\.0\.0\.0.*?host=(\S+)|(\d+\.\d+\.\d+\.\d+))")
test_str = ("Foo bar ip=0.0.0.0 baz host=YOLO-PC foobar bazinga\n\n"
"Foo bar ip=12.23.34.45 baz host=FOOBAR-PC foobar bazinga")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")