// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"ip=(?|0\.0\.0\.0.*?host=(\S+)|(\d+\.\d+\.\d+\.\d+))").unwrap();
let string = "Foo bar ip=0.0.0.0 baz host=YOLO-PC foobar bazinga
Foo bar ip=12.23.34.45 baz host=FOOBAR-PC foobar bazinga";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}