import Foundation
let pattern = #"ip=(?|0\.0\.0\.0.*?host=(\S+)|(\d+\.\d+\.\d+\.\d+))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Foo bar ip=0.0.0.0 baz host=YOLO-PC foobar bazinga
Foo bar ip=12.23.34.45 baz host=FOOBAR-PC foobar bazinga
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)