$re = '/ip=(?|0\.0\.0\.0.*?host=(\S+)|(\d+\.\d+\.\d+\.\d+))/';
$str = 'Foo bar ip=0.0.0.0 baz host=YOLO-PC foobar bazinga
Foo bar ip=12.23.34.45 baz host=FOOBAR-PC foobar bazinga';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);