using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"questions\/([0-9A-Za-z]+?)\/";
string input = @"http://stackoverflow.com/questions/24a34b83c72/js-regex-get-values-between-two-characters";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}