$re = '/questions\/([0-9A-Za-z]+?)\//';
$str = 'http://stackoverflow.com/questions/24a34b83c72/js-regex-get-values-between-two-characters';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);