package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`questions\/([0-9A-Za-z]+?)\/`)
var str = `http://stackoverflow.com/questions/24a34b83c72/js-regex-get-values-between-two-characters`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}