const regex = /questions\/([0-9A-Za-z]+?)\//;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('questions\\\/([0-9A-Za-z]+?)\\\/', '')
const str = `http://stackoverflow.com/questions/24a34b83c72/js-regex-get-values-between-two-characters`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}