// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"questions\/([0-9A-Za-z]+?)\/").unwrap();
let string = "http://stackoverflow.com/questions/24a34b83c72/js-regex-get-values-between-two-characters";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}